
  <!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.timesnewspapers.com/content/tncms/live/" />
<meta name="keywords" content="webster-kirkwoodtimes, news, education" />
<meta name="news_keywords" content="webster-kirkwoodtimes, news, education" />
<meta name="description" content="The Webster Groves School District Board of Education announced at its regular Monday night meeting on June 8 that graduation for Webster Groves High School will be held either June" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="google-site-verification" content="cuLyoSVT-ulUMXnNwnQWNTsBr6j-C5xazN2WH8kB5dM" />
<meta name="msvalidate.01" content="51206FD779C217DB4ABF4A1F75E38C2C" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=400%2C400" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="400" />
<meta property="og:title" content="School Board Narrows Webster Groves High School Graduation Dates To June 26 or 27" />
<meta property="og:description" content="The Webster Groves School District Board of Education announced at its regular Monday night meeting on June 8 that graduation for Webster Groves High School will be held either June" />
<meta property="og:site_name" content="Webster-Kirkwood Times, Inc." />
<meta property="og:section" content="Webster-Kirkwood Times" />
<meta property="article:publisher" content="https://www.facebook.com/WebsterKirkwoodTimes/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@WKTimes" />
<meta name="twitter:image:alt" content="wgsd" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.98968f638d68f28a0f12493ae176ad84.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.f5e0209e8fa74e9037c8703df61fdb9c.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans:400,700|Playfair+Display:400,700"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.59905c960650c756bd917d9e081675c9.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/webster-kirkwoodtimes","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":189},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"742a4cbc-aa67-11ea-8f98-eb596bc9320d","app":"editorial"},"google":{"ua":"UA-128702563-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.c34c594a0128ca26764dd8ecad278707.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.ac87000c8e1356e20584473075fd0f2e.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/ads/impressions.js?_dc=1591761933.temp"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/ads/traffic.js?_dc=1591680934"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/ads/settings.js?_dc=1572532032"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"button_size":"btn-lg","button_style":"danger","button_text":"Contribute","button_url":"\/contribute","card_shape":"rounded_rectangle","content_text":"Now, more than ever, the world needs trustworthy reporting\u2014but good journalism isn\u2019t free. Please support us by making a contribution.","content_text_color":"light","content_text_shadow":"enabled","display_again":"24","display_timer":"1","display_triggers":"visitor_enter","headline_shadow":"enabled","headline_size":"large","headline_text":"Support Local Journalism","headline_text_color":"light","image":{},"image_display":"background","overlay_action":"centered","utm_campaign_name":"contribute","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","card_shadow":"enabled","bg_color":"","outline_color":"#ccc","border_width":"5","sticker_shape":"disabled","sticker_color":"#333333","sticker_icon":"exclamation","sticker_icon_color":"white","lead_in":"","lead_text_color":"dark","lead_text_shadow":"disabled","info_text":"","info_text_color":"dark","info_text_shadow":"disabled","enable_email":"","require_user_account":"","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","utm_tracking":"0","utm_source":"blox","utm_medium":"utility_promo_designer","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","show_audience":"","hide_audience":"","block_id":"896056"}); /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1591351266"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1562190615"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>School Board Narrows Webster Groves High School Graduation Dates To June 26 or 27 | Webster-Kirkwood Times | timesnewspapers.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #333; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #c40017; } .fixed-nav #main-navigation { background-color: #c40017 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer-container, #site-footer { background-color: #DEE1E5; color: #000000; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #fff; } .navbar-toggle .icon-bar { background-color: #fff !important; } .navbar-toggle .sr-only-show { color: #fff !important; } #site-top-nav .list-inline>li>a { color: #333; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #fff; } }#site-copyright a, #site-footer a { color: #000000; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /* BASE STYLES */ html {font-size:10px;} body {font-family:'Open Sans', sans-serif;} .btn {transition:all .25s ease-in-out;} .btn-primary {background-color:#222; border-color:#222;} .btn-primary:hover, .btn-primary:focus {background-color:#000; border-color:#000;} .btn-warning {background-color:#FFCE34; border-color:#FFCE34;} .btn-warning:hover, .btn-warning:focus {background-color:#D8B02B; border-color:#D8B02B;} .btn-success {background-color:#275B33; border-color:#275B33;} .btn-success:hover, .btn-success:focus {background-color:#1F4929; border-color:#1F4929;} .btn-danger {background-color:#BD2106; border-color:#BD2106;} .btn-danger:hover, .btn-danger:focus {background-color:#980901; border-color:#980901;} .label-primary {background-color:#222; border-color:#222;} .label-warning {background-color:#FFCE34; border-color:#FFCE34;} .label-success {background-color:#275B33; border-color:#275B33;} .label-danger {background-color:#BD2106; border-color:#BD2106;} .nav-pills>li.active>a, .nav-pills>li.active>a:focus, .nav-pills>li.active>a:hover {background-color:#000;} .progress-bar {background-color:#275B33;} .offcanvas-drawer {background:black;} /* HEADER STYLES */ #main-navigation {height:75px;} .navbar-brand img {max-height:55px;} .navbar-toggle {margin-top:20px;} /* BODY STYLES */ .page-title .block-title, .tnt-no-margin-bottom .card {margin-bottom:0!important;} .block-title-inner {padding:1px 10px!important; border-bottom:1px solid rgba(0,0,0,0);} .block-title-inner * {font-family:'Playfair Display', serif; font-weight:700; text-transform:uppercase;} .main-sidebar .block-title {background:rgba(0,0,0,0);} .main-sidebar .block-title-inner {background:rgba(0,0,0,0);} .asset-body .social-share-links {text-align:left!important;} /* FOOTER STYLES */ footer .block-title {background:rgba(0,0,0,0);} footer .block-title-inner {background:rgba(0,0,0,0);} /* MEDIA QUERIES */ @media (min-width:1200px) { #main-navigation {height:auto;} } /* Support Local Journalism - Christine */ .tnc-overlay .promo-design button.close { opacity: 1; color:#FFFFFF; } /* Place CSS for an umbrella site or any URL that needs specific CSS rules here. */ </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.timesnewspapers.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/d78387a0-e133-11e8-8a39-6f7a09a9791f.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    <link rel="alternate" type="application/rss+xml" title="School Board Narrows Webster Groves High School Graduation Dates To June 26 or 27 | Webster-Kirkwood Times | timesnewspapers.com" href="http://www.timesnewspapers.com/search/?f=rss&amp;t=article&amp;c=webster-kirkwoodtimes&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" />
            
    <script defer src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.a8c7e0dc594b3a0b53141cdea833eee5.js"></script>
            <meta name="robots" content="noindex" />
        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-742a4cbc-aa67-11ea-8f98-eb596bc9320d section-webster-kirkwoodtimes type-article infinity-disabled" data-path="/webster-kirkwoodtimes">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.timesnewspapers.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.template.version=3.155.0&tncms.page.grid=boxy&tncms.page.style=default&tncms.page.path=%2Fwebster-kirkwoodtimes&tncms.page.syndicated=false&tncms.page.reaction=false&tncms.page.app=editorial&tncms.page.theme=flex&tncms.page.skin=flex-editorial&tncms.page.http_status=200&tncms.subscription.required=false&tncms.vendor.outbrain=Headlines+and+photo+grid&tncms.vendor.taboola=&tncms.ad.vendor=blox&tncms.system.render_time=189&tncms.client.is_bot=no&tncms.client.is_gdpr=no&tncms.asset.id=742a4cbc-aa67-11ea-8f98-eb596bc9320d&tncms.asset.app=editorial&tncms.google.ua=UA-128702563-1&tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.timesnewspapers.com",
  secureDomain: "timesnewspapers.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container">

    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-668048" class="tncms-block hidden-md hidden-lg"><div id="user-controls-668048" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.timesnewspapers.com/users/signup/?referer_url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.timesnewspapers.com/users/login/?referer_url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.timesnewspapers.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-668048').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.timesnewspapers.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.timesnewspapers.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.timesnewspapers.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-668048').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.timesnewspapers.com/users/logout/" id="user-logout-form-668048"><input type="hidden" name="referer_url" value="https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/webster-kirkwoodtimes/news/breaking/"  class="nav-link tnt-section-breaking">Breaking</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/news/elections/"  class="nav-link tnt-section-elections">Elections</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/news/updates/"  class="nav-link tnt-section-updates">Updates</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/news/local_government/"  class="nav-link tnt-section-local-government">Local Government</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/news/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/news/crime_report/"  class="nav-link tnt-section-area-crime-reports">Area Crime Reports</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/features/"  class="nav-link tnt-section-features">Features</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/webster-kirkwoodtimes/features/community_spotlight/"  class="nav-link tnt-section-community-spotlight">Community Spotlight</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/features/stories/"  class="nav-link tnt-section-feature-stories">Feature Stories</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/features/special_sections/"  class="nav-link tnt-section-special-section">Special Section</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/site/forms/online_services/letter_editor"  class="nav-link tnt-section-submit-a-letter-to-the-editor">Submit a Letter to the Editor</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/opinion/letters/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/opinion/bitikofer/"  class="nav-link tnt-section-dwight-bitikofer">Dwight Bitikofer</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/opinion/corrigan/"  class="nav-link tnt-section-don-corrigan">Don Corrigan</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/opinion/bufe/"  class="nav-link tnt-section-mary-bufe">Mary Bufe</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/opinion/guest_columnist/"  class="nav-link tnt-section-guest-columnist">Guest Columnist</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/opinion/community_corona_thoughts/"  class="nav-link tnt-section-community-coronavirus-thoughts">Community Coronavirus Thoughts</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/webster-kirkwoodtimes/community/business_notes/"  class="nav-link tnt-section-business-notes">Business Notes</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/community/hometowners/"  class="nav-link tnt-section-hometowners">Hometowners</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/community/times_travels/"  class="nav-link tnt-section-times-travels">Times Travels</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/arts_and_entertainment/"  class="nav-link tnt-section-arts-ent">Arts & Ent.</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/webster-kirkwoodtimes/arts_and_entertainment/art_scrawl/"  class="nav-link tnt-section-art-scrawl">Art Scrawl</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/arts_and_entertainment/book_reviews/"  class="nav-link tnt-section-book-reviews">Book Reviews</a>
                                </li><li>
                                    <a href="/calendar/art/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/arts_and_entertainment/dvd_reviews/"  class="nav-link tnt-section-dvd-reviews">DVD Reviews</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/arts_and_entertainment/fall_arts_preview/"  class="nav-link tnt-section-fall-arts-preview">Fall Arts Preview</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/arts_and_entertainment/reel_world/"  class="nav-link tnt-section-reel-world">Reel World</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/features/special_sections/spring_arts_preview/"  class="nav-link tnt-section-spring-arts-preview">Spring Arts Preview</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-6" data-target="#mobile-nav-right_menu-child-6">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/site/forms/online_services/obit"  class="nav-link tnt-section-place-an-obituary">Place an Obituary</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/obituaries"  class="nav-link tnt-section-view-obituaries">View Obituaries</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a href="/webster-kirkwoodtimes/sports/high_school/"  class="nav-link tnt-section-high-school-sports">High School Sports</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/sports/features/"  class="nav-link tnt-section-sports-features">Sports Features</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/sports/stlsportspage/"  class="nav-link tnt-section-stl-sports-page">STL Sports Page</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/sports/turkey_day/"  class="nav-link tnt-section-turkey-day">Turkey Day</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/webster-kirkwoodtimes/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a href="/webster-kirkwoodtimes/multimedia/photo_galleries/"  class="nav-link tnt-section-photo-galleries">Photo Galleries</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/community/times_travels/"  class="nav-link tnt-section-times-travels">Times Travels</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/multimedia/videos/"  class="nav-link tnt-section-videos">Videos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-9" data-target="#mobile-nav-right_menu-child-9">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-9" class="collapse nav navbar-nav"><li>
                                    <a href="/temporary_classifieds/"  class="nav-link tnt-section-place-a-classified-ad">Place a Classified Ad</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/classified_info/free_ads/"  class="nav-link tnt-section-free-ads">Free Ads</a>
                                </li><li>
                                    <a href="/webster-kirkwoodtimes/classified_info/garage_sale_extras/"  class="nav-link tnt-section-garage-sale-extras">Garage Sale Extras</a>
                                </li><li>
                                    <a href="/classifieds/vehicle?l=25"  class="nav-link tnt-section-cars-vehicles">Cars & Vehicles</a>
                                </li><li>
                                    <a href="/classifieds/job?l=25"  class="nav-link tnt-section-employment">Employment</a>
                                </li><li>
                                    <a href="/classifieds/sale?l=25"  class="nav-link tnt-section-merchandise">Merchandise</a>
                                </li><li>
                                    <a href="/classifieds/notices?l=25"  class="nav-link tnt-section-notices">Notices</a>
                                </li><li>
                                    <a href="/classifieds/personals?l=10"  class="nav-link tnt-section-personals">Personals</a>
                                </li><li>
                                    <a href="/classifieds/housing?l=25"  class="nav-link tnt-section-real-estate">Real Estate</a>
                                </li><li>
                                    <a href="/classifieds/service?l=25"  class="nav-link tnt-section-services">Services</a>
                                </li></ul></div></div></div>
                <div id="tncms-region-nav-mobile-nav-right-below" class="tncms-region-nav"></div>
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-704390" class="tncms-block"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist">
<div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title">
<a href="/southcountytimes/" class="nav-link tnt-section-southcountytimes">South County Times</a>
                        </div>
                    </div>
</div>
					<div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title">
<a href="/webster-kirkwoodtimes/" class="nav-link tnt-section-webster-kirkwoodtimes">Webster-Kirkwood Times</a>
                        </div>
                    </div>
</div>
					<div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title">
<a href="/westendword/" class="nav-link tnt-section-westendword">West End Word</a>
                        </div>
                    </div>
</div>
</div></div><div id="tncms-block-668044" class="tncms-block hidden-md hidden-lg"><section id="block-668044" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-668044" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-668044" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-668044-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-668044-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-668044-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-668044').submit();
        return false;
    });

    $('#site-search-668044').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-668044 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-668044 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-668044-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    

    

    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list"><li class="dropdown">
                <a class="nav-link nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/" >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="topbar-col-one-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-mail-subscription-services"  href="/site/forms/mail_subscription_services" >
                    <span class="nav-label">Mail Subscription Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-webster-kirkwood-times"  href="/webster-kirkwoodtimes/" >
                    <span class="nav-label">Webster-Kirkwood Times</span>
                </a></li><li>
                <a class="nav-link  tnt-section-west-end-word"  href="/westendword/" >
                    <span class="nav-label">West End Word</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-about-us"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/about.html" >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">About Us</span>
                </a><ul id="topbar-col-one-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-company-history"  href="/site/company_history.html" >
                    <span class="nav-label">Company History</span>
                </a></li><li>
                <a class="nav-link  tnt-section-terms-of-service"  href="/site/terms.html" >
                    <span class="nav-label">Terms of Service</span>
                </a></li><li>
                <a class="nav-link  tnt-section-privacy-policy"  href="/site/privacy.html" >
                    <span class="nav-label">Privacy Policy</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-advertise"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/advertise.html" >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Advertise</span>
                </a><ul id="topbar-col-one-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-2020-media-kit"  href="/media_kit/" >
                    <span class="nav-label">2020 Media Kit</span>
                </a></li><li>
                <a class="nav-link  tnt-section-2020-rate-card"  href="/rate_card/" >
                    <span class="nav-label">2020 Rate Card</span>
                </a></li><li>
                <a class="nav-link  tnt-section-2020-classified-rate-card"  href="/classified_rate_card/" >
                    <span class="nav-label">2020 Classified Rate Card</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-a-sales-representative"  href="mailto:advertising@timesnewspapers.com" >
                    <span class="nav-label">Contact a Sales Representative</span>
                </a></li><li>
                <a class="nav-link  tnt-section-contact-classified-department"  href="mailto:classifieds@timesnewspapers.com" >
                    <span class="nav-label">Contact Classified Department</span>
                </a></li><li>
                <a class="nav-link  tnt-section-place-a-classified-ad"  href="/temporary_classifieds/" >
                    <span class="nav-label">Place a Classified Ad</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-delivery"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"   >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Delivery</span>
                </a><ul id="topbar-col-one-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-how-does-your-newspaper-get-to-you"  href="/site/how_does_your_newspaper_get_to_you.html" >
                    <span class="nav-label">How Does Your Newspaper Get to You?</span>
                </a></li><li>
                <a class="nav-link  tnt-section-delivery-issues"  href="/site/forms/delivery_services/delivery_issues/" >
                    <span class="nav-label">Delivery Issues</span>
                </a></li><li>
                <a class="nav-link  tnt-section-vacation-stoprestart"  href="/site/forms/delivery_services/vacation/" >
                    <span class="nav-label">Vacation Stop/Restart</span>
                </a></li><li>
                <a class="nav-link  tnt-section-pick-up-a-paper"  href="/site/pick_up_a_paper.html" >
                    <span class="nav-label">Pick Up A Paper</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-contact-us"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/site/contact.html" >
                    
                        <span class="fas tnt-caret-1"></span>
                    <span class="nav-label">Contact Us</span>
                </a><ul id="topbar-col-one-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-staff-directory"  href="/site/staff.html" >
                    <span class="nav-label">Staff Directory</span>
                </a></li><li>
                <a class="nav-link  tnt-section-print-ads"  href="mailto:advertising@timesnewspapers.com" >
                    <span class="nav-label">Print Ads</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classified-ads"  href="mailto:classifieds@timesnewspapers.com" >
                    <span class="nav-label">Classified Ads</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="mailto:obits@timesnewspapers.com" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-newsroom"  href="mailto:newsroom@timesnewspapers.com" >
                    <span class="nav-label">Newsroom</span>
                </a></li><li>
                <a class="nav-link  tnt-section-circulation"  href="mailto:delivery@timesnewspapers.com" >
                    <span class="nav-label">Circulation</span>
                </a></li><li>
                <a class="nav-link  tnt-section-subscriptions"  href="mailto:delivery@timesnewspapers.com" >
                    <span class="nav-label">Subscriptions</span>
                </a></li><li>
                <a class="nav-link  tnt-section-social-media"  href="mailto:socialmedia@timesnewspapers.com" >
                    <span class="nav-label">Social Media</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-letter-to-the-editor"  href="/site/forms/online_services/letter_editor/" >
                    <span class="nav-label">Submit a Letter to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-submit-a-story-idea"  href="/site/forms/online_services/submit_a_story_idea/" >
                    <span class="nav-label">Submit A Story Idea</span>
                </a></li></ul></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-668047" class="tncms-block"><div id="user-controls-668047" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.timesnewspapers.com/users/signup/?referer_url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.timesnewspapers.com/users/login/?referer_url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.timesnewspapers.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-668047').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.timesnewspapers.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.timesnewspapers.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.timesnewspapers.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-668047').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.timesnewspapers.com/users/logout/" id="user-logout-form-668047"><input type="hidden" name="referer_url" value="https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-674610" class="tncms-block"><div class="follow-links-674610 pull-right">
    
    <section id="block-674610" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/WebsterKirkwoodTimes/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/WKTimes/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCwVlqBYmsy2xM3FUwK8coCA/videos" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.timesnewspapers.com",
  "sameAs" : ["https://www.facebook.com/WebsterKirkwoodTimes/","http://twitter.com/WKTimes/","https://www.youtube.com/channel/UCwVlqBYmsy2xM3FUwK8coCA/videos"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-one" class="tncms-region "><div id="tncms-block-676551" class="tncms-block"><section id="block-676551" class="block emphasis-h3   " ><div class="block"><a href="/webster-kirkwoodtimes" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/6d37eea2-a233-11e8-bd73-9f50578d0d34.jpg?resize=200%2C61 200w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/6d37eea2-a233-11e8-bd73-9f50578d0d34.jpg?resize=300%2C92 300w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/6d37eea2-a233-11e8-bd73-9f50578d0d34.jpg?resize=400%2C122 400w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/6d37eea2-a233-11e8-bd73-9f50578d0d34.jpg?resize=540%2C165 540w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/6d37eea2-a233-11e8-bd73-9f50578d0d34.jpg 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Webster-Kirkwood Times"></a></div></section></div></div></div>
    <div id="masthead-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-668049" class="tncms-block"><div id="weather-668049" class="weather-current size-medium pull-right">
    <ul class="list-unstyled">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=63119" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                        <span class="pull-left btn btn-xs btn-danger weather-alert-btn" data-toggle="tooltip" data-placement="right" title="Weather Alert"><i class="fas tnt-exclamation-triangle"></i></span>
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc medium">
                    <span class="temp">83&deg;</span>
                    
                        <span class="cond">Clear <i class="fas tnt-caret-down"></i></span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="63119"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-668049 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    St. Louis, MO
                                
                                 <small>(63119)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Clear to partly cloudy. A stray shower or thunderstorm is possible. Low 68F. Winds SSW at 10 to 15 mph..</p>
                            <h5>Tonight</h5>
                            <p>Clear to partly cloudy. A stray shower or thunderstorm is possible. Low 68F. Winds SSW at 10 to 15 mph.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: June 9, 2020 @ 10:53 pm</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip=63119"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>

    <div class="clearfix"></div>
</div></div></div>
    <div id="masthead-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-masthead-col-three" class="tncms-region "><div id="tncms-block-668043" class="tncms-block"><section id="block-668043" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-668043" class="search-form-container card clearfix text-center hidden-print well">
    <form id="site-search-668043" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
        <input type="hidden" name="nfl" value="ap">
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-lg ">
        <input id="site-search-668043-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-668043-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-668043-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-668043').submit();
        return false;
    });

    $('#site-search-668043').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-668043 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-668043 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-668043-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>
                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-670002" class="tncms-block"><section id="block-670002" class="block emphasis-h3   " ><div class="block"><a href="/webster-kirkwoodtimes" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/7a61df70-a233-11e8-87de-db9b487a4b71.png?resize=200%2C61 200w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/7a61df70-a233-11e8-87de-db9b487a4b71.png?resize=300%2C92 300w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/7a61df70-a233-11e8-87de-db9b487a4b71.png?resize=400%2C122 400w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/7a61df70-a233-11e8-87de-db9b487a4b71.png?resize=540%2C165 540w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/custom/image/7a61df70-a233-11e8-87de-db9b487a4b71.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Webster-Kirkwood Times"></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                <div id="tncms-region-nav-main-nav-right-nav" class="tncms-region-nav"><ul id="main-nav-right-nav_menu" class="nav navbar-nav"></ul></div>
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/news/" >
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-breaking"  href="/webster-kirkwoodtimes/news/breaking/" >
                    <span class="nav-label">Breaking</span>
                </a></li><li>
                <a class="nav-link  tnt-section-elections"  href="/webster-kirkwoodtimes/news/elections/" >
                    <span class="nav-label">Elections</span>
                </a></li><li>
                <a class="nav-link  tnt-section-updates"  href="/webster-kirkwoodtimes/news/updates/" >
                    <span class="nav-label">Updates</span>
                </a></li><li>
                <a class="nav-link  tnt-section-local-government"  href="/webster-kirkwoodtimes/news/local_government/" >
                    <span class="nav-label">Local Government</span>
                </a></li><li>
                <a class="nav-link  tnt-section-education"  href="/webster-kirkwoodtimes/news/education/" >
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link  tnt-section-area-crime-reports"  href="/webster-kirkwoodtimes/news/crime_report/" >
                    <span class="nav-label">Area Crime Reports</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-features"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/features/" >
                    <span class="nav-label">Features</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-community-spotlight"  href="/webster-kirkwoodtimes/features/community_spotlight/" >
                    <span class="nav-label">Community Spotlight</span>
                </a></li><li>
                <a class="nav-link  tnt-section-feature-stories"  href="/webster-kirkwoodtimes/features/stories/" >
                    <span class="nav-label">Feature Stories</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-special-section"  data-toggle="dropdown" data-target="#" data-nested="menu"   href="/webster-kirkwoodtimes/features/special_sections/" >
                    
                        <span class="fas tnt-caret-right"></span>
                    <span class="nav-label">Special Section</span>
                </a><ul id="main-nav_menu-child-2-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-college-prep"  href="/webster-kirkwoodtimes/features/special_sections/college_prep/" >
                    <span class="nav-label">College Prep</span>
                </a></li><li>
                <a class="nav-link  tnt-section-day-trips-overnights-fall"  href="/webster-kirkwoodtimes/features/special_sections/day_trips_overnights_-_fall/" >
                    <span class="nav-label">Day Trips & Overnights - Fall</span>
                </a></li><li>
                <a class="nav-link  tnt-section-day-trips-overnights-spring"  href="/webster-kirkwoodtimes/features/special_sections/day_trips_overnights_-_spring/" >
                    <span class="nav-label">Day Trips & Overnights - Spring</span>
                </a></li><li>
                <a class="nav-link  tnt-section-education-enrichment"  href="/webster-kirkwoodtimes/features/special_sections/education_enrichment/" >
                    <span class="nav-label">Education & Enrichment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-health-professional-profiles-spring"  href="/webster-kirkwoodtimes/features/special_sections/health_professional_profiles" >
                    <span class="nav-label">Health Professional Profiles - Spring</span>
                </a></li><li>
                <a class="nav-link  tnt-section-health-professional-profiles-fall"  href="/webster-kirkwoodtimes/features/special_sections/health_professional_profiles_-_fall/" >
                    <span class="nav-label">Health Professional Profiles - Fall</span>
                </a></li><li>
                <a class="nav-link  tnt-section-home-garden-resource-guide"  href="/webster-kirkwoodtimes/features/special_sections/home_garden_resource/" >
                    <span class="nav-label">Home & Garden Resource Guide</span>
                </a></li><li>
                <a class="nav-link  tnt-section-hometown-business-profiles"  href="/webster-kirkwoodtimes/features/special_sections/hometown_business_profiles/" >
                    <span class="nav-label">Hometown Business Profiles</span>
                </a></li><li>
                <a class="nav-link  tnt-section-personal-finance"  href="/webster-kirkwoodtimes/features/special_sections/personal_finance" >
                    <span class="nav-label">Personal Finance</span>
                </a></li><li>
                <a class="nav-link  tnt-section-prime-times"  href="/webster-kirkwoodtimes/features/special_sections/prime_times/" >
                    <span class="nav-label">Prime Times</span>
                </a></li><li>
                <a class="nav-link  tnt-section-real-estate-agent-profiles"  href="/webster-kirkwoodtimes/features/special_sections/real_estate_agent_profiles/" >
                    <span class="nav-label">Real Estate Agent Profiles</span>
                </a></li><li>
                <a class="nav-link  tnt-section-refresh-renew"  href="/webster-kirkwoodtimes/features/special_sections/refresh_renew/" >
                    <span class="nav-label">Refresh & Renew</span>
                </a></li><li>
                <a class="nav-link  tnt-section-senior-service-profiles"  href="/webster-kirkwoodtimes/features/special_sections/senior_service_profiles/" >
                    <span class="nav-label">Senior Service Profiles</span>
                </a></li><li>
                <a class="nav-link  tnt-section-summer-camp-education-program-guide"  href="/webster-kirkwoodtimes/features/special_sections/summer_camp_education_program_guide/" >
                    <span class="nav-label">Summer Camp Education Program Guide</span>
                </a></li><li>
                <a class="nav-link  tnt-section-total-home-care"  href="/webster-kirkwoodtimes/features/special_sections/total_home_care/" >
                    <span class="nav-label">Total Home Care</span>
                </a></li><li>
                <a class="nav-link  tnt-section-webster-groves-school-district-directory"  href="/webster-kirkwoodtimes/features/special_sections/webster_groves_school_district_directory/" >
                    <span class="nav-label">Webster Groves School District Directory</span>
                </a></li><li>
                <a class="nav-link  tnt-section-wg-community-days-2019-program"  href="/webster-kirkwoodtimes/features/special_sections/wg_community_days/" >
                    <span class="nav-label">WG Community Days 2019 Program</span>
                </a></li><li>
                <a class="nav-link  tnt-section-women-in-business"  href="/webster-kirkwoodtimes/features/special_sections/women_in_business/" >
                    <span class="nav-label">Women In Business</span>
                </a></li></ul></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-submit-a-letter-to-the-editor"  href="/site/forms/online_services/letter_editor" >
                    <span class="nav-label">Submit a Letter to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-letters-to-the-editor"  href="/webster-kirkwoodtimes/opinion/letters/" >
                    <span class="nav-label">Letters to the Editor</span>
                </a></li><li>
                <a class="nav-link  tnt-section-dwight-bitikofer"  href="/webster-kirkwoodtimes/opinion/bitikofer/" >
                    <span class="nav-label">Dwight Bitikofer</span>
                </a></li><li>
                <a class="nav-link  tnt-section-don-corrigan"  href="/webster-kirkwoodtimes/opinion/corrigan/" >
                    <span class="nav-label">Don Corrigan</span>
                </a></li><li>
                <a class="nav-link  tnt-section-mary-bufe"  href="/webster-kirkwoodtimes/opinion/bufe/" >
                    <span class="nav-label">Mary Bufe</span>
                </a></li><li>
                <a class="nav-link  tnt-section-guest-columnist"  href="/webster-kirkwoodtimes/opinion/guest_columnist/" >
                    <span class="nav-label">Guest Columnist</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community-coronavirus-thoughts"  href="/webster-kirkwoodtimes/opinion/community_corona_thoughts/" >
                    <span class="nav-label">Community Coronavirus Thoughts</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/community/" >
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-business-notes"  href="/webster-kirkwoodtimes/community/business_notes/" >
                    <span class="nav-label">Business Notes</span>
                </a></li><li>
                <a class="nav-link  tnt-section-hometowners"  href="/webster-kirkwoodtimes/community/hometowners/" >
                    <span class="nav-label">Hometowners</span>
                </a></li><li>
                <a class="nav-link  tnt-section-times-travels"  href="/webster-kirkwoodtimes/community/times_travels/" >
                    <span class="nav-label">Times Travels</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-arts-ent"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/arts_and_entertainment/" >
                    <span class="nav-label">Arts & Ent.</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-art-scrawl"  href="/webster-kirkwoodtimes/arts_and_entertainment/art_scrawl/" >
                    <span class="nav-label">Art Scrawl</span>
                </a></li><li>
                <a class="nav-link  tnt-section-book-reviews"  href="/webster-kirkwoodtimes/arts_and_entertainment/book_reviews/" >
                    <span class="nav-label">Book Reviews</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/art/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-dvd-reviews"  href="/webster-kirkwoodtimes/arts_and_entertainment/dvd_reviews/" >
                    <span class="nav-label">DVD Reviews</span>
                </a></li><li>
                <a class="nav-link  tnt-section-fall-arts-preview"  href="/webster-kirkwoodtimes/arts_and_entertainment/fall_arts_preview/" >
                    <span class="nav-label">Fall Arts Preview</span>
                </a></li><li>
                <a class="nav-link  tnt-section-reel-world"  href="/webster-kirkwoodtimes/arts_and_entertainment/reel_world/" >
                    <span class="nav-label">Reel World</span>
                </a></li><li>
                <a class="nav-link  tnt-section-spring-arts-preview"  href="/webster-kirkwoodtimes/features/special_sections/spring_arts_preview/" >
                    <span class="nav-label">Spring Arts Preview</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-obituaries"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a><ul id="main-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-place-an-obituary"  href="/site/forms/online_services/obit" >
                    <span class="nav-label">Place an Obituary</span>
                </a></li><li>
                <a class="nav-link  tnt-section-view-obituaries"  href="/webster-kirkwoodtimes/obituaries" >
                    <span class="nav-label">View Obituaries</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/sports/" >
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-high-school-sports"  href="/webster-kirkwoodtimes/sports/high_school/" >
                    <span class="nav-label">High School Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports-features"  href="/webster-kirkwoodtimes/sports/features/" >
                    <span class="nav-label">Sports Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-stl-sports-page"  href="/webster-kirkwoodtimes/sports/stlsportspage/" >
                    <span class="nav-label">STL Sports Page</span>
                </a></li><li>
                <a class="nav-link  tnt-section-turkey-day"  href="/webster-kirkwoodtimes/sports/turkey_day/" >
                    <span class="nav-label">Turkey Day</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-multimedia"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/webster-kirkwoodtimes/multimedia/" >
                    <span class="nav-label">Multimedia</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-photo-galleries"  href="/webster-kirkwoodtimes/multimedia/photo_galleries/" >
                    <span class="nav-label">Photo Galleries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-times-travels"  href="/webster-kirkwoodtimes/community/times_travels/" >
                    <span class="nav-label">Times Travels</span>
                </a></li><li>
                <a class="nav-link  tnt-section-videos"  href="/webster-kirkwoodtimes/multimedia/videos/" >
                    <span class="nav-label">Videos</span>
                </a></li></ul></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-9" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-place-a-classified-ad"  href="/temporary_classifieds/" >
                    <span class="nav-label">Place a Classified Ad</span>
                </a></li><li>
                <a class="nav-link  tnt-section-free-ads"  href="/webster-kirkwoodtimes/classified_info/free_ads/" >
                    <span class="nav-label">Free Ads</span>
                </a></li><li>
                <a class="nav-link  tnt-section-garage-sale-extras"  href="/webster-kirkwoodtimes/classified_info/garage_sale_extras/" >
                    <span class="nav-label">Garage Sale Extras</span>
                </a></li><li>
                <a class="nav-link  tnt-section-cars-vehicles"  href="/classifieds/vehicle?l=25" >
                    <span class="nav-label">Cars & Vehicles</span>
                </a></li><li>
                <a class="nav-link  tnt-section-employment"  href="/classifieds/job?l=25" >
                    <span class="nav-label">Employment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-merchandise"  href="/classifieds/sale?l=25" >
                    <span class="nav-label">Merchandise</span>
                </a></li><li>
                <a class="nav-link  tnt-section-notices"  href="/classifieds/notices?l=25" >
                    <span class="nav-label">Notices</span>
                </a></li><li>
                <a class="nav-link  tnt-section-personals"  href="/classifieds/personals?l=10" >
                    <span class="nav-label">Personals</span>
                </a></li><li>
                <a class="nav-link  tnt-section-real-estate"  href="/classifieds/housing?l=25" >
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link  tnt-section-services"  href="/classifieds/service?l=25" >
                    <span class="nav-label">Services</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
                
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-896056" class="tncms-block tnc-overlay"><div class="modal promo-designer-modal in centered " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true" >
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-896056" class="block emphasis-h3   " ><div class="promo-design"><div class="card-bg-color rounded_rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button>
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline large light text-shadow">
                            Support Local Journalism
                        </div>
                    
                    
                        <p class="text light text-shadow">
                            Now, more than ever, the world needs trustworthy reporting—but good journalism isn’t free. Please support us by making a contribution.
                        </p>
                    <div class="promo-design-button">
                            <a href="/contribute">
                                <button type="button" class="btn btn-danger btn-lg">Contribute</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div><div id="tncms-block-667936" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-667937" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div><div id="modal-image-a430fece-aa67-11ea-9edf-0b6e79db4516" class="modal fullscreen in modal-image image-default modal-a430fece-aa67-11ea-9edf-0b6e79db4516" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=400%2C400"
                    srcset="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=300%2C300 300w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=400%2C400 400w"
                    sizes="100vw"
                    width="400"
                    height="400"
                    alt="wgsd"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-a430fece-aa67-11ea-9edf-0b6e79db4516" data-target=".caption-inner-modal-image-a430fece-aa67-11ea-9edf-0b6e79db4516">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-a430fece-aa67-11ea-9edf-0b6e79db4516 collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.timesnewspapers.com%2Fwgsd%2Fimage_a430fece-aa67-11ea-9edf-0b6e79db4516.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/wgsd/image_a430fece-aa67-11ea-9edf-0b6e79db4516.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a430fece-aa67-11ea-9edf-0b6e79db4516"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=wgsd&via=WKTimes&url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwgsd%2Fimage_a430fece-aa67-11ea-9edf-0b6e79db4516.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/wgsd/image_a430fece-aa67-11ea-9edf-0b6e79db4516.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a430fece-aa67-11ea-9edf-0b6e79db4516"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.timesnewspapers.com/wgsd/image_a430fece-aa67-11ea-9edf-0b6e79db4516.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/wgsd/image_a430fece-aa67-11ea-9edf-0b6e79db4516.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a430fece-aa67-11ea-9edf-0b6e79db4516"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.timesnewspapers.com/tncms/asset/editorial/a430fece-aa67-11ea-9edf-0b6e79db4516" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"a430fece-aa67-11ea-9edf-0b6e79db4516"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWebster-Kirkwood%20Times%2C%20Inc.%5D%20wgsd&body=https%3A%2F%2Fwww.timesnewspapers.com%2Fwgsd%2Fimage_a430fece-aa67-11ea-9edf-0b6e79db4516.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"a430fece-aa67-11ea-9edf-0b6e79db4516"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/wgsd/image_a430fece-aa67-11ea-9edf-0b6e79db4516.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"a430fece-aa67-11ea-9edf-0b6e79db4516"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-a430fece-aa67-11ea-9edf-0b6e79db4516-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="a430fece-aa67-11ea-9edf-0b6e79db4516" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="a430fece-aa67-11ea-9edf-0b6e79db4516" class="save-list-a430fece-aa67-11ea-9edf-0b6e79db4516-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="a430fece-aa67-11ea-9edf-0b6e79db4516" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-a430fece-aa67-11ea-9edf-0b6e79db4516 img { max-height: 400px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="asset article-default"  data-url="https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=400%2C400">
            <meta itemprop="width" content="400">
            <meta itemprop="height" content="400">
        </div>
        <meta itemprop="name" content="timesnewspapers.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.timesnewspapers.com\/tncms\/search\/mlt\/?origin=742a4cbc-aa67-11ea-8f98-eb596bc9320d&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="asset-paging">
                <div id="paging-prev-742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="paging-link prev offset"></div>
                <div id="paging-next-742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="tnt-flag label label-flag label-flag-default label-flag-featured">featured</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            School Board Narrows Webster Groves High School Graduation Dates To June 26 or 27
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2020-06-09T09:45:00-05:00" class="tnt-date asset-date text-muted">
            Jun 9, 2020
        </time>
    </li>
            <li class="hidden-print"><time datetime="2020-06-09T09:45:00-05:00" class="tnt-date asset-date text-muted">
            Jun 9, 2020
        </time><span class="text-muted">Updated </span><time datetime="2020-06-09T11:12:21-05:00" class="tnt-date asset-date text-muted">11 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2020-06-09T09:45:00-05:00">
    <meta itemprop="datePublished" content="2020-06-09T09:45:00-05:00">
    <meta itemprop="dateModified" content="2020-06-09T06:12:21-05:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=School%20Board%20Narrows%20Webster%20Groves%20High%20School%20Graduation%20Dates%20To%20June%2026%20or%2027&via=WKTimes&url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.timesnewspapers.com/tncms/asset/editorial/742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWebster-Kirkwood%20Times%2C%20Inc.%5D%20School%20Board%20Narrows%20Webster%20Groves%20High%20School%20Graduation%20Dates%20To%20June%2026%20or%2027&body=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="742a4cbc-aa67-11ea-8f98-eb596bc9320d">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=School%20Board%20Narrows%20Webster%20Groves%20High%20School%20Graduation%20Dates%20To%20June%2026%20or%2027&via=WKTimes&url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.timesnewspapers.com/tncms/asset/editorial/742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWebster-Kirkwood%20Times%2C%20Inc.%5D%20School%20Board%20Narrows%20Webster%20Groves%20High%20School%20Graduation%20Dates%20To%20June%2026%20or%2027&body=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-742a4cbc-aa67-11ea-8f98-eb596bc9320d-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="742a4cbc-aa67-11ea-8f98-eb596bc9320d" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="save-list-742a4cbc-aa67-11ea-8f98-eb596bc9320d-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="742a4cbc-aa67-11ea-8f98-eb596bc9320d" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <div class="inline-asset inline-image layout-square  subscriber-hide  tnt-inline-asset tnt-inline-relcontent tnt-inline-image tnt-inline-relation-child tnt-inline-presentation-default tnt-inline-alignment-left tnt-inline-width-half"><figure class="photo layout-square hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-a430fece-aa67-11ea-9edf-0b6e79db4516" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-a430fece-aa67-11ea-9edf-0b6e79db4516" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="400">
            <meta itemprop="height" content="400">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg">
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="wgsd"
                            class="img-responsive lazyload full default"
                            width="400"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=300%2C300 300w, https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/content/tncms/assets/v3/editorial/a/43/a430fece-aa67-11ea-9edf-0b6e79db4516/5edfada3f2cf1.image.jpg?resize=400%2C400 400w" />
            </div>
                
                
            </div>
            
                
                
            
        </figure></div><p>The Webster Groves School District Board of Education announced at its regular Monday night meeting on June 8 that graduation for Webster Groves High School will be held either June 26 or 27 at an undetermined location.</p><p>Though the board previously had dates in both June and July reserved at the Chaifetz Arena in downtown St. Louis, Superintendent Dr. John Simpson said he didn’t feel like the district had the ability to work in the space due to social distancing requirements.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p>“The likelihood of us being in a spot where we can have a normal graduation is unlikely,” Simpson said. “It’s best to plan around a set of dates and do what’s best for the kids and then look for an opportunity in the not too distant future to gather them all as alumni and make that a very special event.”</p><p>Simpson mentioned the possibility of a “drive-up” graduation, in which students approach a stage in their cars and then exit to walk across it, or socially distancing in a large arena with adequate seating.</p><p>More details will be announced soon regarding location and attendance capacity, he said, but parents should plan for an outdoor graduation. Simpson added that Moss Field, located on the campus of Hixson Middle School, is a possible location. Webster Groves High School graduation is typically held on Moss Field.</p><p>“We hope to have more information out soon,” Simpson said, noting the date is only a few weeks away. “I know it’s not soon enough.”</p><p><strong>Coronavirus Update</strong></p><p>Simpson said the district has not yet made a decision on whether or not to allow students in school buildings at the beginning of the 2020-2021 school year. The option being explored the most, he said, is a hybrid model of on and off-site learning.</p><p>“We continue to operate in this world of the unknown. Information is coming in at quite a rapid pace and as we approach the school year, we’re trying to develop a number of different schooling models as it relates to the current status of the virus and how families choose to respond,” he said.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p>Simpson added that a top priority is increasing the engagement of students during virtual learning sessions. Simpson said he has been in touch with several local churches, the administration of which are discussing the possibility of donating space and guidance for extracurricular learning.</p><p>The district has not yet reached a decision on whether or not transportation including school busses will be offered next year.</p><p>Assistant Superintendent of Human Resources Dr. Sandy Wiley Skinner said that the HR department has been “very busy” creating guidelines for allowing teachers back into the building. The process will begin June 15, she said, and while all buildings will remain closed to the public, limited numbers of teachers and staff will be permitted into their classrooms and offices as needed.</p><p>The district is still analyzing the need for additional staff, and at least one staff member has resigned due to a partner transitioning out of St. Louis.</p><p>Chief Financial/Operating Officer Pam Frazier said that she had submitted a FEMA grant and hopes that the district will be reimbursed for personal protective equipment, electronics, sanitation goods and other items purchased in the wake of the COVID-19 pandemic.</p><p><strong>Board Reorganization</strong></p><p>New board member Allen Todd, who won his seat during the June 2 election, was sworn in during the meeting, as were returning members Amy Clendennen, David Addison and Jo Doll.</p><p>David Addison was nominated and accepted the role of board president. Jo Doll accepted the position of vice president. JoAnn Kite retained her position as treasurer and Shari Meyers retained her position as secretary.</p><p>Simpson gave a fond farewell to Assistant Superintendent for Learning Dr. Kris Denbow, who is retiring from the district after many years of service.</p><p>“I am grateful for the opportunity,” said Denbow. “I’m so thankful for your support.”</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=School%20Board%20Narrows%20Webster%20Groves%20High%20School%20Graduation%20Dates%20To%20June%2026%20or%2027&via=WKTimes&url=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.timesnewspapers.com/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.timesnewspapers.com/tncms/asset/editorial/742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BWebster-Kirkwood%20Times%2C%20Inc.%5D%20School%20Board%20Narrows%20Webster%20Groves%20High%20School%20Graduation%20Dates%20To%20June%2026%20or%2027&body=https%3A%2F%2Fwww.timesnewspapers.com%2Fwebster-kirkwoodtimes%2Fschool-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27%2Farticle_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/webster-kirkwoodtimes/school-board-narrows-webster-groves-high-school-graduation-dates-to-june-26-or-27/article_742a4cbc-aa67-11ea-8f98-eb596bc9320d.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"742a4cbc-aa67-11ea-8f98-eb596bc9320d"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-742a4cbc-aa67-11ea-8f98-eb596bc9320d-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="742a4cbc-aa67-11ea-8f98-eb596bc9320d" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="742a4cbc-aa67-11ea-8f98-eb596bc9320d" class="save-list-742a4cbc-aa67-11ea-8f98-eb596bc9320d-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="742a4cbc-aa67-11ea-8f98-eb596bc9320d" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("832ed22d-3ce2-4937-9f93-e56306b8315c");
        var apiKey = "YDC2G9T2K4BXNCJ3XDMR";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-832ed22d-3ce2-4937-9f93-e56306b8315c';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div>

                    <div class="asset-comments hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-691137" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-one1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-one","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691145" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691146" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-three1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-three","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691147" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-four1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-four","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691148" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-five1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-five","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691150" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-six1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-six","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691151" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-seven1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-seven","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691152" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-eight1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-eight","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691153" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-nine1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-nine","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-691154" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-ten1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-ten","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-701787" class="tncms-block">
        <div id="blox-ad-position-block-rectangle-eleven1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-rectangle-eleven","slot":"1","fold":"","width":"300","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-667945" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-668033" class="tncms-block"></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-667938" class="tncms-block hidden-xs hidden-sm">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"","width":"927","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-667939" class="tncms-block visible-xs visible-sm">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-668036" class="tncms-block"><section id="block-668036" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-668036 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-i-class-fas-tnt-home-i"  href="/webster-kirkwoodtimes/" >
                    <span class="nav-label"><i class="fas tnt-home"></i></span>
                </a></li><li>
                <a class="nav-link  tnt-section-news"  href="/webster-kirkwoodtimes/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link  tnt-section-features"  href="/webster-kirkwoodtimes/features/" >
                    <span class="nav-label">Features</span>
                </a></li><li>
                <a class="nav-link  tnt-section-opinion"  href="/webster-kirkwoodtimes/opinion/" >
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link  tnt-section-community"  href="/webster-kirkwoodtimes/community/" >
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link  tnt-section-arts-entertainment"  href="/webster-kirkwoodtimes/arts_and_entertainment/" >
                    <span class="nav-label">Arts & Entertainment</span>
                </a></li><li>
                <a class="nav-link  tnt-section-obituaries"  href="/webster-kirkwoodtimes/obituaries/" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link  tnt-section-sports"  href="/webster-kirkwoodtimes/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link  tnt-section-multimedia"  href="/webster-kirkwoodtimes/multimedia/" >
                    <span class="nav-label">Multimedia</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-667987" class="tncms-block"><section id="block-667987" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-667987 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link  tnt-section-archives"  href="/search/" >
                    <span class="nav-label">Archives</span>
                </a></li><li>
                <a class="nav-link  tnt-section-calendar"  href="/calendar/" >
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link  tnt-section-classifieds"  href="/classifieds/" >
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link  tnt-section-mail-subscriber-services"  href="/site/forms/mail_subscription_services/" >
                    <span class="nav-label">Mail Subscriber Services</span>
                </a></li><li>
                <a class="nav-link  tnt-section-media-kit"  href="/media_kit/" >
                    <span class="nav-label">Media Kit</span>
                </a></li><li class="dropdown">
                <a class="nav-link dropdown-toggle  tnt-section-newspaper-delivery"  data-toggle="dropdown" data-target="#"   href="/site/forms/delivery_services" >
                    <span class="nav-label">Newspaper Delivery</span>
                </a><ul id="footer-col-two-nav_menu-child-6" class="dropdown-menu"><li>
                <a class="nav-link  tnt-section-delivery-issues"  href="/site/forms/delivery_issues" >
                    <span class="nav-label">Delivery Issues</span>
                </a></li><li>
                <a class="nav-link  tnt-section-how-do-you-get-your-newspaper"  href="/site/how_does_your_newspaper_get_to_you.html" >
                    <span class="nav-label">How Do You Get Your Newspaper?</span>
                </a></li><li>
                <a class="nav-link  tnt-section-vacation-stoprestart"  href="/site/forms/delivery_services/vacation" >
                    <span class="nav-label">Vacation Stop/Restart</span>
                </a></li></ul></li><li>
                <a class="nav-link  tnt-section-place-an-ad"  href="/temporary_classifieds/" >
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link  tnt-section-search"  href="/search/" >
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link  tnt-section-weather"  href="/weather/" >
                    <span class="nav-label">Weather</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-674608" class="tncms-block"><section id="block-674608" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-674608 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>www.timesnewspapers.com</strong><br>
    122 W. Lockwood Ave., Second Floor<br>
    St. Louis, MO 63119
    <br>
    
        <strong>Phone:</strong> 314-968-2699<br>
        <strong>Email:</strong> <a href="mailto:info@timesnewspapers.com">info@timesnewspapers.com</a><br>
    
</address></section></div><div id="tncms-block-674609" class="tncms-block padding-bottom"><div class="follow-links-674609 default">
    
    <section id="block-674609" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-674609 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/WebsterKirkwoodTimes/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/WKTimes/" title="Twitter" target="_blank" rel="noopener" class="btn btn-md btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCwVlqBYmsy2xM3FUwK8coCA/videos" title="Youtube" target="_blank" rel="noopener" class="btn btn-md btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.timesnewspapers.com",
  "sameAs" : ["https://www.facebook.com/WebsterKirkwoodTimes/","http://twitter.com/WKTimes/","https://www.youtube.com/channel/UCwVlqBYmsy2xM3FUwK8coCA/videos"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                



<!-- Begin Constant Contact Active Forms -->
<script> var _ctct_m = "f1eefbe270b652f98106224442f842c6"; </script>
<script id="signupScript" src="//static.ctctcdn.com/js/signup-form-widget/current/signup-form-widget.min.js" async defer></script>
<!-- End Constant Contact Active Forms -->


            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-667991" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-667991"><div class="col-md-7"><small>&copy; Copyright 2020 <a href="/">Webster-Kirkwood Times, Inc.</a>, 122 W. Lockwood Ave., Second Floor St. Louis, MO</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/timesnewspapers.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/webster-kirkwoodtimes","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("742a4cbc-aa67-11ea-8f98-eb596bc9320d")});});
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    </script>
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script>/*<![CDATA[*/ !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/timesnewspapers.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script></body>
</html>